Wi-Fi connected but Internet not working on macOS? Try this!

wi-fi-issues
Wi-Fi connected but Internet not working on macOS? Try this!
0.0 0

#1

Whenever I wake up in the morning (or night), I used to open my MacBook Pro and listen to some music to clear my mind, but quite recently, it took some time for my device to get connected to the Internet. Like 30 minutes or even more. My Wi-Fi connected with full signal strength but my internet connection was not working, at all. These are the things I already tried on my macOS device:

  • Turning off/on the Wi-Fi option.

  • Turning off/on the Wi-Fi router/modem.

  • Resetting a couple of Network settings.

But, unfortunately, it was not helpful at all. But then, I came across this tweak/trick/tip via a friend online, and I didn’t believe it’ll help me, to be honest. But it did…

Click on the “Apple” menu > “System Preferences” option > “Network” icon.

You’ll find a window like this:

By default, the Location will be “Automatic,” click on that and select “Edit Locations.”

Add a random name here; we used “DeviceBAR” for the location name.

Network%20Location%20Name%20macOS%20DeviceBAR

Click on the “Done” button and then click on the “Apply” button to save the changes.

After this, it just took a few seconds to propagate, and my internet connection started to work instantly.

The default “Automatic” location will “automatically provide settings for any network ports that it detects are available.” We are just resetting that I believe and it worked quickly. I found this solution pretty handy, if you are facing any such issues, do check it out and let us know a well. :slight_smile: