"The disk you inserted was not readable by this computer" HDD [Solutions]

"The disk you inserted was not readable by this computer" HDD [Solutions]
0.0 0

#1

I got a new external hard disk drive (HDD) recently, it’s Western Digital My Passport, but, unfortunately, optimized for Windows OS. When I tried to connect it to my Mac, I got this strange error:

I got annoyed, again, I tried to access it by checking Disk Utility, it was there, but I was not able to do anything there.

I wanted to use this HDD for “Time Machine,” so I thought, why not use this directly skipping the error/warning. I opened Time Machine and did the necessary steps, but when I tried to erase the content, I got this error:

“MediaKit reports not enough space on device for requested operation.” - I was like, WTF, it’s a brand new storage device, why am I facing this. I’m not able to do anything with this now. Then I came across this excellent guide from My Cyber Universe (Thank you Arthur Gareginyan!) and followed the steps, tada, it’s working now!

I’m just sharing the steps I followed; I took some screenshots when I did this:

  1. Open “Terminal.”

  2. Type: diskutil unmountDisk force disk2

(We are using disk2 for this, but if it’s something different, kindly replace!)

  1. Then, type: sudo dd if=/dev/zero of=/dev/rdisk2 bs=1024 count=1024

  2. Now, type: diskutil partitionDisk disk2 GPT JHFS+ "DeviceBAR" 0g

(Replace DeviceBAR with the name you want!)

That’s all! Now, you can access your external HDD or Pen drive without any issue. This is how it looks like for us:

Disk Utility for DeviceBAR Drive shows like this…

At first, I was really annoyed, but now, it’s just another stuff I learned and loved. If you have any queries or facing any issues, let us know. :slight_smile: